Rubicon Owners Forum banner

21 - 37 of 37 Posts

·
Registered
Joined
·
2,172 Posts
The dots really irritate me. It also seems to lock up and not respond. I do have country internet though.
I have to use Explorer for work and don't have the energy to switch browsers.
Yeah, it's still slow for me. I notice also that I am not seeing anything from regular members. I wonder if it's because it's a pita to find stuff. I am pretty sure I preferred the old forum at this point.
 

·
Moderator
Joined
·
3,328 Posts
I'm not really digging the new format. I am trying to be patient to see if I can get used to it...
 

·
Premium Member
Joined
·
958 Posts
I access ROF and a couple other forums almost exclusively from my phone using Tapatalk. Aside from a couple spam adds early on there has been no noticeable change for me. The app puts all my forums in one common interface. Each is separate of course within that interface, but all navigation is consistent among them.
 

·
Registered
Joined
·
2,172 Posts
I access ROF and a couple other forums almost exclusively from my phone using Tapatalk. Aside from a couple spam adds early on there has been no noticeable change for me. The app puts all my forums in one common interface. Each is separate of course within that interface, but all navigation is consistent among them.
I use my phone mostly for access. I did go online and pages seem to load faster, it's just slow on my phone.
 

·
Moderator
Joined
·
3,328 Posts
It seems as though this new format only works well on selected browsers. I don't like that the solution for anyone having issues is to change their browser...it is essentially telling the customer "you are wrong...you fix it"
 

·
Administrator
Joined
·
435 Posts
Discussion Starter #34
I don't see a "mark as read" button.
How To Mark Forums Read

If you want to mark a specific forum as read, navigate to that forum. At the top you will see a button to “Mark All Read.

If you want to mark all threads in the community as read, click on NEW near the upper right-hand corners of the site.

Click on Mark All Read.

You will then see a popup confirming that this is what you want to do. Click “Mark All Read”.

- Cricket
 

·
Registered
Joined
·
483 Posts
Change to chrome, still have white dots and now some lightning bolts. I assume this is the test forum before implementing to more popular ones.
 

·
Premium Member
Joined
·
1,320 Posts
Yeah, this is about as trashed up a UI as I have ever seen put on Xenforo. Somebody had to put some effort into making it this bad.

Among other things - sets off my spamware alarms like crazy. This site is so loaded with data gathering and advertising/monetization schemes it's unreal.

It's faster if you don't log in. I presume because after login every click is being tracked for possible "personalized" advertising opportunities.

All that said... The site actually works. Which is more than I can say for the old one. Half the time I couldn't even read or post on the old one.

But, ownership doesn't see this as a community. Just a cost/benefit, profit/loss scenario. Everything they do is about monetizing what little traffic this site still gets. And nothing else.

- DAA
 
21 - 37 of 37 Posts
Top