Rubicon Owners Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
263 Posts
Discussion Starter #1
Anyone else have any problems?

Picked up my Rubicon in the last week of November. It has since been in the shop for these reasons.

1) First week of December it had a knocking noise, took it in the passenger side rear tire lugnuts were loose.

2) January had a loud band on and off coming from rear axle at cruising speeds, took it in they couldnt find anything.

3) March club run to Land Between The Lakes in Kentucky/Tennessee (three states away) on the way home that loud bang from the rear axle came back again. Got so loud and evil sounding I had to pull to the side of interstate and wait for help with hood up. 1/2 hour gone by noone stops so I say screw it stopped by some relatives in Kentucky and took it to the dealer in town where they kept it all day, found a nut inside the E-Brake housing, said it was not missing anywhere but it was the same nut that hold the axle in place. They said it was probably from the assembly line.

4) April had problems getting the rear axle to unlock and couldnt use E-Brake for awhile, took it in couldnt find anything wrong with either.

5) Late April made a funny noise when I started it, took it in they had to replace the starter.

6) Last week motor was making a chugging air noise, took it in and the had to replace the tension pully.

7) Saturday 5-24 whole thing started to shake in the seat, and shook really bad when turning motor off when parking, I have to pull in to the dealer tomorrow and raise hell. :bad-words: Brother in law had same problem in December with his X and they had to replace a oxygen sensor I think.

So I really had to bad mouth a Jeep, but this thing is really a piece. I will never not drive a Jeep, just hope they will take care of me at the dealer if I keep having problems. :wtf:

ANYONE?
 

·
Premium Member
Joined
·
4,195 Posts
Wow sounds like your really having some problems....seems to me like the bolt or nut you found in the factory says it all...carelessness on that rubicon built..who knows though...is there a lemon law in your state? hope you work though your jeep problems...
Pete
 
G

·
Guest
Joined
·
0 Posts
WOW!!! My only problem with a leaking seal is minor compared to your nightmare. Sounds like it was built on a Monday or Friday the 13th. I had a dodge like that, nothing but problems, where my friends had none.

Ron..
 

·
Registered
Joined
·
1,530 Posts
Holy SH*#........Do you have any mods to it already... I would almost think about trading it in on another one if it wasn't such a hassle.
 

·
Premium Member
Joined
·
3,342 Posts
My only problems were the seatbelt light staying on, the wire was pinched under the seat, fixed by jeep. And my dash temp guage was telling me the thing was overheating, replaced entire instrument cluster under warranty. Hope thats it, sounds like yours was built in a bad batch or something. All I can tell you is keep good records and eventually if you keep having problems you may have a good case to classify it a lemon.
 

·
Premium Member
Joined
·
3,745 Posts
The only problem I've had was a dripping auto transmission. I took it in around 1500 miles and the dealer thought it might be the test ports. I got a free oil change in the process. It still dripped, so I took it back about 8 weeks later. They replaced the pan gasket (or resealed it, I'm not sure the 42RLE has a pan gasket), and gave me another free oil change. And they adjusted my TC linkage - I had installed a 1" BL on it in the interim. No charge. And no more leak.

Jerry
 

·
Premium Member
Joined
·
2,160 Posts
I just realized an axle tube leak. and I have had a funny thump feel sometimes with the tranny. Getting both looked at tomorrow.

Other than that nothing major.

Justin
 

·
Premium Member
Joined
·
4,195 Posts
Since we are posting problems check this one out..I was driving down the highway and my right sun visor just fell off!! :wtf: Good thing the wife wasnt ther or shed be mad..lol..no leaks yet....thank goodness...the tranny makes a constant ticking when idleing but i figure its just the jeep noises...and my breaks clunk when i innitally start..but chrysler gave me a sheet that explained that.......
Pete
 

·
Registered
Joined
·
1,530 Posts
petesjeeprubi said:
Since we are posting problems check this one out..I was driving down the highway and my right sun visor just fell off!! :wtf: Good thing the wife wasnt ther or shed be mad..lol..no leaks yet....thank goodness...the tranny makes a constant ticking when idleing but i figure its just the jeep noises...and my breaks clunk when i innitally start..but chrysler gave me a sheet that explained that.......
Pete
Hey Pete.... That constant ticking is just a JP noise..It came with the NV 3500 and I guess after 3 yrs they have not figured out what the problem is or how to fix it. I have gotten used to the diesel engine sound now :shock:

Sean
 
G

·
Guest
Joined
·
0 Posts
Pete, thats the reversed gear shaft that you are hearing, normal noise for the NV 3550's. Notice it will pretty much go away when you push in the clutch.

Ron
 

·
Registered
Joined
·
1,293 Posts
The only problem I keep having is I can't stop modding the damn thing!

Sorry guys had to break the tension! :)

Really though the only small gripe I have that I will have to bring it in for is my drivers side rear window is a whole lot more loose than the right side. And the top is tearing in the top portion of the rear only whee the buttons for the rear straps are.
 

·
Registered
Joined
·
1,014 Posts
My Issues...
1. Right window would bind on roll up had to have track replaced.
2. Sparrows. front and readr axles replaced.
3. Clutch Slave cyl failed at 1700 miles.
4. seat belt wont fully retrack belt keeps getting hung in door.
5. Wreck at 45 days into ownership 4500.00 damage
 

·
Registered
Joined
·
1,781 Posts
Well I had been running flawless for awhile, now their creeping up.

1. Added a Warn Rear Diff guard and now the rear diff is leaking. I can fix that though.

2. Driver side window binds when going up or down.

3. Rear Locker I believe stopped engaging, the light just blinks.

4. Won't stay in 4-low now that I put a lift on.

Under 2,000 miles, auto-matic, 3.5" lift with 33's, warn diff guards front and rear, warn steering box guard, locker mod.....dealer might get me on that one.
 

·
Premium Member
Joined
·
2,160 Posts
WarPath said:
Well I had been running flawless for awhile, now their creeping up.

1. Added a Warn Rear Diff guard and now the rear diff is leaking. I can fix that though.

2. Driver side window binds when going up or down.

3. Rear Locker I believe stopped engaging, the light just blinks.

4. Won't stay in 4-low now that I put a lift on.

Under 2,000 miles, auto-matic, 3.5" lift with 33's, warn diff guards front and rear, warn steering box guard, locker mod.....dealer might get me on that one.
3. check for pinched air hoses and check all wiring. After my lift was done my front locker air hose was pinched. make sure you didn't pull anything apart.

4. Adjust the shift linkage.

Justin
 

·
Registered
Joined
·
1,781 Posts
LoL

As easy as that sounds, you would have thought I could have checked those.

Thanks man. :D
 

·
Sarcastic Moderator
Joined
·
14,064 Posts
here is my list

3 TC leaks in the first 3 weeks, Dealer had it 14 of the first 21 days I owned it.

Wiring harness hung down interfering with the ckutch

Rear seat fold handle broken (wire not connected)

Driver side rear window won't stay in groove at bottom, will be replaced.

Jeep is 3 months old.

What can I say " It's a Jeep Thing" unfortunately

My 03 Sahara had one minor problem in 17 months and 36K miles. Sometimes I am sorry I didn't just mod my Sahara.

Mike
 
1 - 20 of 26 Posts
Top