Rubicon Owners Forum banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,252 Posts
Discussion Starter #1
It's in the shop, maybe it will be ready Friday afternoon.

I took it in once in January, told them that the indicator lamp seemed to stay on too long after throwing the unlock switch. Mechanic thought it was just the sensor in the axle and replaced it yesterday. I drove around a while and the tires were chirping like it was fully locked but the lamp was not on in the dash. So I went back to the dealer and they looked at it.

"Gee, we don't know much about his new axle, we need to call DCX". Ten minutes later the service mananger is out saying we have ordered parts for it, we sholud be done Friday, would you like a loaner car?"

Hope they fix it right the first time.
 

·
Registered
Joined
·
1,530 Posts
That is the first Locker problem that I have heard of.......Hmmmmm..

I am really happy with my lockers after using them a few times they seem to be engaging in and out faster and better than the first few times I used them...


Got to love warrenty... :D
 

·
Registered
Joined
·
454 Posts
I found that after the first couple of times out I got used to having to slow down or turn the wheels a little to let the two axles turn at the same speed for the lockers to engage. Now I can get the lockers to engage pretty quickly.

The owner's manual doesn't say much about how to use the lockers and when to use them etc. In my mind, this is a good thing because DC can't say "you weren't using them the proper way." Therefore, they can't give you any static when you go in for warantee.
 

·
Premium Member
Joined
·
1,252 Posts
Discussion Starter #4
Got a call from the dealer last night, he said they were just about finished with the repair. They wanted to check it out this morning and if all goes well Rubi will be back home tonight. :)
 

·
Premium Member
Joined
·
1,252 Posts
Discussion Starter #6
The repair order says they replaced the actuator. I've had it in before because the sensor was not working right, causing the dash light to flash on/off all the time. It finally felt like it was not unlocking at all, tires were squealing at every turn. Working perfectly now.
 

·
Registered
Joined
·
263 Posts
I had same problem with my light staying on after unlocking, and the dealership didnt find anything wrong. They did however have to replace my starter last week. Im glad my dealership likes me casue they found water and mud in my starter and left that part out of my service report so it was covered under warranty.
 
G

·
Guest
Joined
·
0 Posts
Another Rubi owner on a different forum told me that his rear locker only partially disenganged and, after driving it home that way, he found a box full of shavings. So this makes the second problem report I'm aware of. But as many different owners I see in here and JU, I don't get the impression this is a wide-spread issue.
 
1 - 8 of 8 Posts
Top