Rubicon Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I just finished installing a new Pioneer AVH-601EX, including a iDatalink Maestro-RR, etc. into our 2012 JKUR. I have one issue concerning the steering wheel controls.

The volume controls on the steering wheel work fine until a user manually uses the volume control on the radio itself. Afterwords, the volume/radio controls on the steering wheel no longer work until the vehicle is turned off and restarted.

Has anyone else experienced this and do they have a potential fix?

Everything else seems to be working correctly otherwise.
 

·
Administrator
Joined
·
10,695 Posts
Oh boy, that's weird. If you bought the head from Crutchfield they might be able to help, it's probably useless to contact Pioneer. There's an AV forum out there but I forgot what it's called - the audiophiles might be able to help.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the tip on the AV site. I will look into it. I did not get the head unit from Crutchfield, but I think it is most likely going to be a Pioneer issue with the software/firmware. I am going to update and hope for the best.
 

·
Registered
Joined
·
13 Posts
I just finished installing a new Pioneer AVH-601EX, including a iDatalink Maestro-RR, etc. into our 2012 JKUR. I have one issue concerning the steering wheel controls.

The volume controls on the steering wheel work fine until a user manually uses the volume control on the radio itself. Afterwords, the volume/radio controls on the steering wheel no longer work until the vehicle is turned off and restarted.

Has anyone else experienced this and do they have a potential fix?

Everything else seems to be working correctly otherwise.

What was wrong with the factory radio?
 
1 - 7 of 7 Posts
Top