Rubicon Owners Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
561 Posts
Discussion Starter #1
Finished my OBA this evening. I used ALL new parts on this install, from the York , down to every last fitting. I managed to cram the oil removal filter on the firewall , right near the back plug. Had to take aprt the filter to get it into the bracket and then put the two pieces back together once it was in, but it fit well, if you follow the stainless braided hose off the comp. you can spot it. Also managed to find a hadley electronic psi switch that was adjustable, and much cleaner looking IMO than a conventional one like I used on my last TJ. Anyway just thought I'd share some pics of the finsihed product. Still have to mount a tank, I bought one, but now think it may be a bit large( kilby 3.5 gallon) So now I'm planning on building one, or trying to buy something that will meet my needs. So if anyone has suggestions for smaller low profile tanks, please point me in the direction.



Oil removal filter:


 
G

·
Guest
Joined
·
0 Posts
Looks really good, not a whole lot of room left after you were done. Another project for my list. I did notice that your pictures are from 6/18/1999. :lol:

Ron
 

·
Registered
Joined
·
561 Posts
Discussion Starter #3
PBR-
Yup things are tight, but everything just fit, and I was able to put it exactly where I wanted for the most part.

and yah I REALLY need to set the date on my cam:D
 

·
Registered
Joined
·
454 Posts
Man, I love the gauge inside the cab. And those switches kick ass. I love the diamond plate!!
 

·
Premium Member
Joined
·
1,184 Posts
Looks great. Do you have a close up pic of the electronic pressure switch. Might be interested in swapping mine out.
Eventually I will run a guage inside. Looks sweet.

I got the 1.75 gallon tank from kilby. Fit nicely under the driver side rear passenger foot area. Right behind the skid.

Have you tested for leaks. My lost air fairly quickly, but since LCIR on Memorial Day weekend, it has been solid at 106PSI. No drop in a week and a half.

Brian
 

·
Registered
Joined
·
561 Posts
Discussion Starter #6
Thanks for the compliments. Yes I have tsted for leaks. Teflon taped every fitting, and seems to be leak free, but will probably loose some air after a few days, weeks, etc. I try not to leave it pressurized anyhow. Especially now since I don't have a tank yet. I actually was checking out the site last night, think I'll try either the 1.75 or the 1.25 gal tanks from kilby.

But even w/o tank it puts out a good a good amount of air! I didnt have a chance to air down and up right off the comp. last night, but will and post my results/times for airing up a 31", 33", and 35" tire w/ and w/o a tank once I get a chance to "test" it more.
 
1 - 6 of 6 Posts
Top