Rubicon Owners Forum banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
4,195 Posts
Discussion Starter #1
Anyone else running the Rubicon Express SF seris kits notice it sure is noisy? The first time I went wheeling it was really noisy, not its not as bad...maby it gets better when broken in...Just wondering......
 
G

·
Guest
Joined
·
0 Posts
Mine was nice and quiet, then the bushing squeezed out and I was metal to metal on the arms. I also noticed that if you unload the springs and get dirt under them they make lots of noise.

Ron
 

·
Registered
Joined
·
1,530 Posts
Check the bushings and the torque on your bolts...
 

·
Premium Member
Joined
·
4,195 Posts
Discussion Starter #4
LILRDJP said:
Check the bushings and the torque on your bolts...
is the possability that i may not have them tight enough or too tight? Also, most of the noises come when wheeling, not on the street.
Pete M
 

·
Registered
Joined
·
1,530 Posts
petesjeeprubi said:
LILRDJP said:
Check the bushings and the torque on your bolts...
is the possability that i may not have them tight enough or too tight? Also, most of the noises come when wheeling, not on the street.
Pete M
Could be that they are not tight enough.....55 ft/lbs for the axle end and 110 ft/lbs for the frame end....110 ft/lbs for the lower front CA at the axle...Did you grease the Jonny Joints on the arms also???

Check all you bolts and also look for the bushing not seated properly fromt the bad batch of RE bushing.

Keep us informed..

Cheers

Sean
 

·
Premium Member
Joined
·
4,195 Posts
Discussion Starter #6
LILRDJP said:
petesjeeprubi said:
LILRDJP said:
Check the bushings and the torque on your bolts...
is the possability that i may not have them tight enough or too tight? Also, most of the noises come when wheeling, not on the street.
Pete M
Could be that they are not tight enough.....55 ft/lbs for the axle end and 110 ft/lbs for the frame end....110 ft/lbs for the lower front CA at the axle...Did you grease the Jonny Joints on the arms also???

Check all you bolts and also look for the bushing not seated properly fromt the bad batch of RE bushing.

Keep us informed..

Cheers

Sean
Thanks....Now i have somthing to do this weekend.....!! When you say bushings not seated properly you mean rubber bushings right?" I did notice some of my rubber bushings at the frame end are coming out of the control arms.....Is this a bad bushing?
Thanks
 

·
Registered
Joined
·
1,530 Posts
petesjeeprubi said:
LILRDJP said:
petesjeeprubi said:
LILRDJP said:
Check the bushings and the torque on your bolts...
is the possability that i may not have them tight enough or too tight? Also, most of the noises come when wheeling, not on the street.
Pete M
Could be that they are not tight enough.....55 ft/lbs for the axle end and 110 ft/lbs for the frame end....110 ft/lbs for the lower front CA at the axle...Did you grease the Jonny Joints on the arms also???

Check all you bolts and also look for the bushing not seated properly fromt the bad batch of RE bushing.

Keep us informed..

Cheers

Sean
Thanks....Now i have somthing to do this weekend.....!! When you say bushings not seated properly you mean rubber bushings right?" I did notice some of my rubber bushings at the frame end are coming out of the control arms.....Is this a bad bushing?
Thanks

Sound like it........Can you snap some photos for us and post them..This will help...I believe you found the problem.:D
 

·
Premium Member
Joined
·
4,195 Posts
Discussion Starter #10
Well here is a pic of my bushing that i think may be the culpret of some vibes.....tell me what you think guys...Pardon all the Uwarrie Mudd..lol

 
G

·
Guest
Joined
·
0 Posts
That looks like the entire sleeve came out of the arm, vice the bushing squeezing out. JKS was haveing a similar issue. RE has changed bushings, (I have 2 sets of new ones). You could wack the arm with a mallet and see if it slides back over, or you could take the arm off and wack the bushing back in if it has come out as one piece. That would transmitt vibes to the frame that would normally be dampened by the bushing. I would clear the metal to metal contact first and see if it goes away.

Ron
 

·
Premium Member
Joined
·
4,195 Posts
Discussion Starter #12
Well i went under the jp and fixed the bushing that was coming out of the arm and it quited up a bit.....but I rechecked it again and now its shifting the other way :( I think these are the poping type noises that I get sometimes when i innitial drive off or back up....I also get a crazy poping noise wheen I shift from 1st to 2nd gear.....It sounds like a shifting noise. Im going to re-check the torc again this weekend. And also to my avail, my stearing wheel is 1/2 cocked to the right again. Back for another alignment I suppose.....any advice on what to check would help alot. thanks..:roll:
 
1 - 12 of 12 Posts
Top