Rubicon Owners Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My pumps for my lockers have been giving me issues lately and now are not working at all. The rear pump wont come on at all and the front pump turns on and pumps but will not build enough pressure to lock in. I have replaced all of the line to make sure that isnt it. I dont mind buying new pumps if that is needed but they seem to be hard to find. Is there any aftermarket pumps or do i need stock, and does anyone know where i can get a couple?
 

·
Jeepless in PA
Joined
·
12,587 Posts
You can buy the stock pump from Jeepsareus.com located here http://www.jeepsareus.com/p/7938693926.html
Price: $289.95
Set of 2 factory Rubicon Air Pumps, one front, one rear on one bracket. For use on air lockers, which run on a low PSI. You can run one or both pumps at the same time or at diffrent times.
For the Axle Lock Switch or wiring and airline from axle to pump. We have these products on our website or call 877-533-7787.


The rear pump wont come on at all and the front pump turns on and pumps but will not build enough pressure to lock in.
I would switch the pumps to see if it is an electrical issue. The front pump may keep pumping if the spring clip that holds the air line to the locker (inside the diff housing) slid off. It is normal for this to happen. Just wiretie or black zip tie and you will be set for life. :)
 

·
Registered
Joined
·
1,431 Posts
You should be able to test the pumps by giving them power and pluging up the output line with your finger. After it builds about 5 or so PSI, the pump should stop.
 

·
Moderator
Joined
·
3,368 Posts
Xs2 on what Greg and seaphan said.

If that doesn't work, then WHILE the diff cover(s) are off, engage the lockers again and then observe what you see and hear inside the diff. If it is still an air leak then it possible could be the air bladder that pumps up and actuate the locker has a leak.
 

·
Premium Member
Joined
·
5,182 Posts
When my TC blew up and destroyed both locker pumps I found the dealer had them and they were about $117 each. Note the wiring plugs are different for front and rear. Like the guys said pull the hose, plug it and turn on the pump. If pump is okay it will shut off quickly. :)
 

·
Registered
Joined
·
281 Posts
Did you change the oil in the diffs and then this showed up?
 

·
Registered
Joined
·
177 Posts
Remove the hose at the locker pump and install a pressure guage with a short piece of hose. Turn on the locker and check the pressure, if not 5 PSI the pump is bad. My front pump gave out recently, replaced with one from Morris 4x4. Many forums have discount codes for this dealership. Also remember their online catalog listed different part numbers for 03 vs. 04-06. They can sell you individual pump or complete bracket with pumps.
 

·
Sarcastic Moderator
Joined
·
14,107 Posts
It also may be the locker switch. There were alot of switch failures in 03s and 04s. Wire the pump directly to 12v and see if they work. If they turn on it is the switch, if they do not it is the pump.
 
1 - 8 of 8 Posts
Top