Rubicon Owners Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
OK... So I've had my RE SF 3.5 Lift for 4 mouths now and come to find out the front axle is not centered. It's about 1inch off center so I'm on the market for an adjustable trackbar. After doing some research I’m beginning to lean towards the JKS Adjustable Trackbar. Does anyone else use this trackbar? What’s the quality of the product? I guess my main concern is how it mounts up. Is it a direct OEM replacement or does it require an extra bracket like the RE one? TIA
 

·
Registered
Joined
·
140 Posts
I installed JKS with my OME-2" lift. Had to drill out the frame hole for the new bolt, but that was it. (They have a trackbar for 2 - 3.5" lift and another for 4"+). Had some struggle removing the stock bar.

Thanks,
Nimo


dCvR~03Rubi said:
OK... So I've had my RE SF 3.5 Lift for 4 mouths now and come to find out the front axle is not centered. It's about 1inch off center so I'm on the market for an adjustable trackbar. After doing some research I’m beginning to lean towards the JKS Adjustable Trackbar. Does anyone else use this trackbar? What’s the quality of the product? I guess my main concern is how it mounts up. Is it a direct OEM replacement or does it require an extra bracket like the RE one? TIA
 
G

·
Guest
Joined
·
0 Posts
I run it with my RE 3.5 lift. I actually run the one for the 4" (OGS 125) and up lift. You will need to open up the frame side mount hole to 9/16" to fit the new bolt. The JKS/OGS/Currie adj. track bar (Yep, same bar different price) fits just like stock otherwise. Some may have a problem with the frame side connection point where the johnny joint is rubbing on the shielding for the locker wires, but I haven't heard of any contact anywhere else. Mine shows a rub, but nothing more than a clean mark on the padding, no tears or rips, so it's incidental contact.

JKS front Adj. Trackbar

Ron
 

·
Premium Member
Joined
·
3,745 Posts
Get the JKS. You won't regret it.

Jerry
 

·
Registered
Joined
·
1,414 Posts
PBR Stitch said:
I run it with my RE 3.5 lift. I actually run the one for the 4" (OGS 125) and up lift. You will need to open up the frame side mount hole to 9/16" to fit the new bolt. The JKS/OGS/Currie adj. track bar (Yep, same bar different price) fits just like stock otherwise. Some may have a problem with the frame side connection point where the johnny joint is rubbing on the shielding for the locker wires, but I haven't heard of any contact anywhere else. Mine shows a rub, but nothing more than a clean mark on the padding, no tears or rips, so it's incidental contact.

JKS front Adj. Trackbar

Ron
FWIW, I just noticed mine had cut completely through the locker wires. But I have only about a 2.5" lift (so far). I also have a pretty good wear mark on track bar from contact with the diff. just below the now cut wires.

Anyone have any ideas how to stop this contact? I know, go higher...soon, but until then....??

Sorry for the minor hi-jacking of the thread.

Nick
 

·
Premium Member
Joined
·
2,772 Posts
I disconnected my locker connector/cable from the axle and tie-wrapped it to the upper driver side CA so it couldn't make contact during flex.

To stop the TB contact, you will need to lengthen your front lower CA's slightly or shorten the front upper CA's slightly to keep within desired pinion and caster angles. By doing this, you rotate the lower part of the axle forward - where it mounts to the TB, and the top part of the axle back - where you are making contact.

This will also reduce any TB binding that might occur when flexed by making the JJ mount perpendicular to the frame mount and by moving the axle bushing mount towards the front, not under the axle.

Good luck

Ken

EDIT: Unfortunately, those wires give the display panel a ground signal when the locker is actually locked. So, I'm guessing you get a flashing indication always now even when locked. Maybe you can splice the wires back together so you will have a steady on when locked and flash when enabled but not actually locked.
 

·
Registered
Joined
·
1,414 Posts
Thanks Ken,

I had the wires spliced and tucked away from the diff cover. I don't have AUCA's. I'll keep an eye on the contact but, so far no binding or noticable noise. Just the small contact mark on the diff and TB.

Nick
 
1 - 7 of 7 Posts
Top