Rubicon Owners Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Has anyone else noticed ignition pinging in first gear - high range under any load? I can also get it to ping in first gear 2 wheel drive, but load level is much higher. Dealer took for test ride and got same pinging, but have no fix for chip at this time. Just wondering if anyone else has this problem and if there is a way to correct.
Second question is there a spark plug upgrade, that meets warranty standards?
 

·
Registered
Joined
·
1,530 Posts
Take it back and ask them to do a distributor sync.. That will solve the prolbem. It is out from the factory..
 

·
Registered
Joined
·
308 Posts
Mine will give a short ping when it's hot and I'm down on the RPMs. Short pings aren't really bad. It's the prolonged pinging that will hurt. (So says the manual.) If it pings for anything over half a second, get it fixed.

Chris
 

·
Registered
Joined
·
126 Posts
LILRDJP said:
Take it back and ask them to do a distributor sync.. That will solve the prolbem. It is out from the factory..
:roll:
My 04 does a lot of pinging. I had it to dealer today w/4700 miles on it.
What did they do on this distributor sync?
Dealer said out west here some brands of fuel are poor. He mentioned AMPM and Union 76 (Rebel)
Sure wish they could fix it!!
This thing is really peppie and almost jumps out from under me. Will kick butt at 80 mph.
Thanks for info, maybe all of rubi owners together will get the fix!
 

·
Registered
Joined
·
69 Posts
Anytime i run the lowest grade (ocatane) of gas I get non stop pinging, if I run mid or premium I am fine. I've had the dealer check my ignition and fuel injection settings 3-4 times, they always claim its set correctly. YMMV
 

·
Registered
Joined
·
126 Posts
LILRDJP said:
Take it back and ask them to do a distributor sync.. That will solve the prolbem. It is out from the factory..
If I mention this to dealer will he know what the heck I am talking about?
Is it a factory fix?
Any help appreciated.
"Ray"
 

·
Registered
Joined
·
247 Posts
I use the lower grade fuel and have not had a single ping. Sounds like the dealer needs to deal with this.
 

·
Registered
Joined
·
49 Posts
Dealer

I have a 04 Rubicon with a Pinging problem after 25000KM and its in the dealer now.
It also pings all the time, Probably software isue.
Hope thay can fix this. My 93 grand Cherokke 4L does not ping nor ever pinged with the old distrubtor style. This software auto timing is crap.
 

·
Registered
Joined
·
3 Posts
I figure for the extra $100 a year, I'm just going to use the 93 octane. That fixed the problem completely and I get an extra 4 MPG out of it (perhaps because I can stay in 5th longer at lower RPM without pinging! :) )
 

·
Premium Member
Joined
·
1,931 Posts
i run 87 in mine and never have any pinging.. i have 11,000 miles and nothing.. knock on wood..
 

·
Registered
Joined
·
521 Posts
Mine pings prettty bad too, I need to get it in, but haven't had a chance becasue of work,,,,keep in mind if you run mid or premium fuel you can cause deposits/soot to build on you rengine and casue issues down the road....My dad used mid in his dodge van and then when they had to tear it down for servicing later the engine had a real bad build up that casued some serious issues...this thing is designed for using low grade fuel and is suppose to work without pinging,,,,,
 

·
Registered
Joined
·
39 Posts
Around 29,000 miles, my rubicon started to ping too. It only does it when it is under heavy load, like downshifting to 3rd or 4th going down the highway and putting it on the floor, and the pinging would start from about 3500-3750 rpm up to redline. I figure that maybe there is a slight amount of carbon buildup in the cylinders that might be just enough to bump the compression ratio up a tiny amount and warrant running mid-grade or premium fuel, but I am too cheap to do it. Day to day driving, it never really does it.
 

·
Registered
Joined
·
49 Posts
Pinging

Yeh i run 91 octane and its gone, Also i tthrew a K7N right on top of the Tbody, No pipes, Put a Valve cover breader on the hole.
Sounds Good and runs good. No PING
:wink:
 

·
Registered
Joined
·
561 Posts
Guess I'm lucky too. About 12000 miles and not a single ping...knock on wood.
 

·
Registered
Joined
·
445 Posts
Aha! And I thought my pinging was caused by an overheat. Mine is only at about 8000KM about 5000Mi and it was pinging on regular fuel even under moderate throttle in almost any gear. I began using midgrade and it went away, but the last week or so it has started doing it with even midgrade.

Perhaps it's time to make a list of thing and have the dealer look at them.
 

·
Registered
Joined
·
42 Posts
Only 8,600 miles on my 04. About 3 weeks ago, got the pinging problem. Pings in every gear around 2000 to 2500 rpms when using regular gas. Been through several tanks of gas; even used half tank of mid grade gas with no real effect. Trying to arrange a time to get dealer to look at it. Would not mind using mid or premium gas to stop the problem, but don't want to cause more problems down the line. Pretty discouraging to buy a new vehicle and have pre-ignition noise before I even hit 10,000 miles. Where is the quality control?
 

·
Registered
Joined
·
49 Posts
Manual

In your manual it says pinging is normal inthe 4L it wont harm anything.
Pinging on floring the pedle to the floor is not right . Its in the manual
 

·
Registered
Joined
·
445 Posts
Re: Manual

Rockcrawler said:
In your manual it says pinging is normal inthe 4L it wont harm anything.
Pinging on floring the pedle to the floor is not right . Its in the manual
The owner's manual? I am positive I read that front to back and don't recall seeing that. Of course, I was distracted by my new shiny Jeep at the time. I'll go through it again.

Perhaps you were referring to the FSM instead, in which case, could I get a page reference?

In any case, I'm going to go back to regular fuel and then use the destructions on this website (err I mean instructions) to reset the computer and re-learn the operational characteristics of the engine/drivetrain and my driving habits and see what happens.
 

·
Registered
Joined
·
49 Posts
Re: Manual

Tinkerer said:
Rockcrawler said:
In your manual it says pinging is normal inthe 4L it wont harm anything.
Pinging on floring the pedle to the floor is not right . Its in the manual
The owner's manual? I am positive I read that front to back and don't recall seeing that. Of course, I was distracted by my new shiny Jeep at the time. I'll go through it again.

Perhaps you were referring to the FSM instead, in which case, could I get a page reference?

In any case, I'm going to go back to regular fuel and then use the destructions on this website (err I mean instructions) to reset the computer and re-learn the operational characteristics of the engine/drivetrain and my driving habits and see what happens.
Howdy.
In the manual that would be page 144 / starting and operating . Fuel Requirements. Half way down the page . Hopefully the manuals are the same in Canada:)
On my page its says Light Spark Knock at low engine speeds is not harmfull to your engine. Howerver continued heavy spark knock at high speeds can cuase damage and immediate service is required. Then it says You keep driving with the knock and your engines is damaged from the knock you not covered under warrenty.
:roll:
 

·
Registered
Joined
·
445 Posts
:roll: Go figure.. "It's normal, but if you keep driving this way, your warranty is void".. so I guess I might as well abuse and mod the h*ll out of it 'cuz I'm not getting any warranty work done in any case :)

Actually, so far I've had good luck with the dealer I take it to <fingers crossed>.

In that case, I'm going back to Regular, the knock wasn't that bad, was only under light throttle and lower RPM's that I recall. It was just disconcerting because other than diesel's, I've never had a vehicle make that noise under "normal operating conditions".

Thanks for the info, I have to wait until I get home to check the manual.. I have two, but neither is in the glove box.
 
1 - 20 of 29 Posts
Top