Rubicon Owners Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
My dad has on 01 TJ and ordered the Highrock bumper, (has the approach roller, and chrome hoop). The holes on this bumper weren't remotely close to lining up. Front to back, side to side, they were off. Of course you say, send it back.....never happen, my dad was set on mounting it. Without giving all the details of a flop of a project, has anyone else experienced this? We were pretty bummed to get that from Highrock. Thanks
 

·
Premium Member
Joined
·
4,924 Posts
I had the same problem. I could get the top bolts in, then not the bottom. or the bottom in, then not the top.

I was dead set on installing it, rather than sending it back so I nosed the jeep in to a loading dock to put pressure on the bumper, then hard on the e-brake, then the holes lined up.

Side to side alignment was good though.

That was 4 years ago.
 

·
Registered
Joined
·
257 Posts
My bumper started life as a highrock. Mine fit fine, and has been on and off many times, during its transformation. After going to 37's, on the first offroad trip I found out at full stuff my tires were grabbing the wings. When I got home, they were tweaked pretty bad. So off the went, and end caps were made and welded on. Then I thought it looked bare, so I welded on a grill guard and stinger. This bumper has taken many shots with no real damage, except the hollow tube (see dent in mine)









 

·
Premium Member
Joined
·
236 Posts
desertfox1 said:
I had the same problem. I could get the top bolts in, then not the bottom. or the bottom in, then not the top.
X2 for me...

I had to work at getting the bottom bolts in. By work I mean grind a little of the holes to just "open" them a little.
 
1 - 4 of 4 Posts
Top