Rubicon Owners Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter #1
Ok, I have a Old radio Shack CB, about 15 years. It has always worked Great. Last run out it stops transmitting voice, when I key the mike, the meter run up & the receiver's meter also runs up , but no voice, I receive fine. Any Ideas? Time to junk it? or is this an EZ fix?
 

·
Registered
Joined
·
50 Posts
could be voice lock being turned down. also, it could be the diaode for the mic. if its the diaode, usually runs about 40.00 to fix it. sometimes it worth it on the old radios since they seem to work/built better than the new ones.
 

·
Premium Member
Joined
·
1,434 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter #9
rubizj wrote:
Buy a new CB - you tight ass!


Junkie - out
I'd rather use yours! Welcome to the RUBICON Forum! :rotflmao:
 

·
Premium Member
Joined
·
1,438 Posts
Not sure if yours has a SWR meter.
But I know on mine, i have to switch to SWR mode to use it. When in this mode, I can recieve transmissions, but I can't transmit.
Check your switches? ;)
 

·
Registered
Joined
·
2 Posts
That's riiight...have I gotten that back yet? Guess what cooler I'm lookin' in when a brother needs a little help?
:beerchug:
 

·
Registered
Joined
·
656 Posts
EZ Fix, sound like your SWR has change. this could be from a loose fitting on either end of the antenna cable, or depending on the type of antenna you're using something comes on loose on the antenna itself.
 

·
Registered
Joined
·
346 Posts
Discussion Starter #14
rubizj wrote:
Buy a new CB - you tight ass!


Junkie - out
Just an update on this thread, Threw the CB in the trash, A buddy gave me a cobra for free. I guess that still makes me a Tight Ass! :laugh:
 
1 - 15 of 15 Posts
Top