Rubicon Owners Forum banner

401 - 412 of 412 Posts

·
Moderator
Joined
·
3,634 Posts
One issue I really want to address is I will need to remove the steering box and better balance the wheel pulley so it doesn’t squeel on startup and chirp for the first little while when warming up.
Are you sure that it is the steering causing the squeal? Usually on start up it will be the alternator causing the squeal since it is working hard to charge the battery.

Good to see you dropping in!
 

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #402
Are you sure that it is the steering causing the squeal? Usually on start up it will be the alternator causing the squeal since it is working hard to charge the battery.

Good to see you dropping in!

The steering box is what I’m thinking but I will look into the alternator to be sure, that would be much easier to address. May get a second opinion because it is a complicated belt line. Possibly the York could be causing the issue so more homework on the matter wouldn’t be a bad idea.
 

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #403
So I pulled the rig out of the shop this week and snapped some updated photos. Still so many projects to tackle but the rig is running great and super fun to drive. Nothing like going 65 mph and stomping on the skinny and getting pushed back into the seat. Impressive really given the rig is pretty darn heavy. Anyway here are some of the highlights...


Took the boy to Virginia City today, he wanted to go off road and climb a mountain. lol






https://i.imgur.com/dMBLiRN.jpg


Looks like a new format to loading images so hopefully these work. More to come...
 

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #404
75497



75498



75499



75500



75502
 

Attachments

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #405
Oh heck yeah, ROF hosts the Photos!


75504
 

·
Administrator
Joined
·
11,207 Posts
I see your PSC steering reservoir, mine got crammed in a little farther forward. Are you running the OEM brake booster?

That LS really, really looks great in there! (y)
 

·
Registered
Joined
·
237 Posts
Looks great!!!
 

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #408
I see your PSC steering reservoir, mine got crammed in a little farther forward. Are you running the OEM brake booster?

That LS really, really looks great in there! (y)
Yes the booster is stock. Not sure if it’s because I have Dana 60 axles but this rig stops without any issue. Very strong brakes, more so than the LJ on 315’s. The LJ is likely getting Blaine’s upgraded braking system, currently as is the LJ need improvement in that dept.

Appreciate it. I am pleased with how things are coming along.

Looks great!!!

Thanks man. One day things will all come together and I I’ll finally be able to paint and call her done.
 

·
Administrator
Joined
·
11,207 Posts
My brain wasn't engaged - with D60 axles you already have big brakes :rolleyes:!

Blaine installed hydro brake 'booster' along with hydro assist steering. My big brake kit brakes are twice as effective with the hydro booster, it was a stunning improvement.
 

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #411

·
Premium Member
Joined
·
3,356 Posts
Discussion Starter #412
Put the ole girl to work today. Heater is getting replaced in the shop tomorrow so had to shuffle some boats around in the shop to make room. Effortless moving with the rig and easy to maneuver around in tight quarters too.


75581
 
  • Like
Reactions: Mouse
401 - 412 of 412 Posts
Top