Brake issue - help! - Rubicon Owners Forum
 3Likes
  • 2 Post By rlenglish
  • 1 Post By SteveVB
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-24-2018, 08:14 PM Thread Starter
Rubi Noobie
 
Join Date: Mar 2018
Posts: 1
Garage
Brake issue - help!

I have a 2012, two door, Rubicon with soft brake pedal. The pedal goes to the floor once engine is started.
Has been to 3 different shops including the dealership with no resolution.
The following has been replaced: 4 calipers (powerstop), 4 rotors (powerstop), all pads, 4 braided lines, master cylinder, brake booster, ABS module, vacuum pump and has been bench/pressure bled. There are no apparent leeks in the lines.
Any ideas?
Jeff Baird is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-24-2018, 08:41 PM
Rubicus Maximus
 
Join Date: Mar 2017
Location: B.C. Canada
Posts: 462
Does your vehicle stop properly? We run into a lot of people who have a vehicle that stops properly but they can overcome the pedal and push it to the floor. If this is the case, it's normal. find another Jeep to compare.
If your pedal goes to the floor when you stop then I suspect you have air in the system. You can normally bleed JK's all you want but you won't get a good pedal. You have to bleed them then go through a abs bleed procedure with a scan tool, you must follow the instructions on the scan tool. then you will probably have to repeat the bleed procedure again. That will fix you up.
A lot of tech's don't know this or they don't follow the instructions properly.
SteveVB and FLLJ like this.

2014 JKU, JKS lift,Poison spyder flares, bombshell covers,Rancho D2 control arms, JKS adjustable track bars, 35" Tires. GrabBars, Crawler Conceptz rear bumper, Smitty front bumper, Winch. Rough Country inner fenders, Teraflex Disco Mud Flaps
Backseat Dobermann Security
rlenglish is offline  
post #3 of 4 (permalink) Old 03-25-2018, 09:39 AM
Administrator
 
johncanfield's Avatar
 
Join Date: Oct 2010
Location: Texas Hill Country
Posts: 10,339
Garage
Welcome to ROF! Didn't we have a guy on here from Germany with the very same problem on a new JKRU?

John - WB5THT
=======================
2006 LJ, not stock
johncanfield is offline  
 
post #4 of 4 (permalink) Old 03-25-2018, 02:55 PM
Rubicus Maximus
 
SteveVB's Avatar
 
Join Date: Mar 2004
Location: Laytonsville, MD
Posts: 771
The pedal will go to the floor when started as the vacuum boost builds. So if brakings is ok, it may be normal, but if it was a change in condition then suspect what ever was done just prior.

Were all those parts replaced to fix the bad pedal feel or you just saying they've been replaced?

What were the conditions when the pedal first went to the floor?

What did you change in order? Order is important...

Bad bleeding job, bad master bleed, bad master, bad booster would be guesses from most probable, add in mistakes in installation of any of the components since they've been replaced. Braided lines I would inspect carefulluy. Bad part numbers (discs or pads)
johncanfield likes this.

Steve

2004 Sienna Pearl
no front bumper extensions
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
some scrapes, dents and some skids ,UCF high clearance skid, Hybrid 3" lift w/tera 3", Bilstein 5100s, F&RATB, JJ control arms , on 255/85 KM2's

2013 crush JKU AEV bling 285/75-17s

2006 TJ project truck GR8Tops, flat fenders , 34s , 6' bed are the plan

Last edited by SteveVB; 03-25-2018 at 02:57 PM.
SteveVB is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Rubicon Owners Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Summer returns and so does my brake issue. Wildrat General Tech 19 07-31-2016 08:38 AM
LJ Brake Issue skycamscott General Tech 3 12-01-2008 08:20 PM
RE brake line issue?? funinmud TJ Suspension and Steering, Tires and Wheels 9 10-03-2008 11:27 AM
RE 3.5 Superflex on 05 LJ - rear trackbar issue + line issue scrapple TJ Suspension and Steering, Tires and Wheels 11 07-18-2008 10:47 AM
RE Rear Brake Line and E-Brake Cable Questions? Jeep4Rox TJ Drivetrain and Horsepower 7 02-09-2006 02:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome